Issue: when Agent A initiates consult transfer/conference to Agent B from Agent-Desktop , “confirm” button is disabled/greyed out to Agent A after Agent B receives/answers the call.
Issue Description:
Agent A logged into Agent-Desktop with valid LAN ID and station ID and receives call then does consult transfers/conference the call to skill/agent list.
Agent B logged into Agent-Desktop with different LAN ID and station ID. Agent B receives the call. Now, Agent A should be able to see “confirm” button. But here Agent A can not see “confirm” button as it is greyed out. Also UCID receiving is all 0’s from AES.
Troubleshooting/Initial Analysis:
- Please make sure that agents are using different station ID.
- Make sure Agent A has received the call.
- Check for exception/error in TMAC server logs. If so, we need to resolve that.
- Check for “remote connected” keyword in TMAC server logs.
In above screenshot (example), Agent B (service.nto:1004) receives the call, onconnect event in tmac server then for agent A (2001:1003) says type=TransferRemoteConnected. If we see “TransferRemoteConnected” then there won’t be issue with TMAC server end.
5.Check TMAC server logs for UCID and it should be unique. If we are receiving all 0’s for UCID then something needs to be checked from avaya CM side.
UCID information is received from avaya AES-> CM to our application.
6. Please check for UCID settings in Avaya CM.
Root Cause:
- UCID receiving all 0’s from Avaya CM end.
- UCID related settings is not valid in Avaya CM.
Resolution/Fix:
We should have below settings in Avaya CM for UCID.
Post these changes we can restart TMAC server and re-login to Agent-Desktop. Then “confirm” button should be visible and should work fine. Also UCID we are receiving unique id’s.