Supervisor

Duplicate Agent List in Agent Desktop-Supervisor Module

Issue Description:

In the 'Active Agents' Section of the Agent Desktop- Supervisor console , the agent names are duplicate meaning there are two records for the same agents.

duplicate agent list

Cause:

When we see the agents list duplicate , we need to check the TMAC Data Server component which is the data source for the above.

The TMAC Data Server will fetch the logged in agents based on the team id. So we need to check the configuration of the TMAC Data Server component and logs for the same.

When we check the configuration of the TMAC Data Server , template.config and TMC_Data.json . the TMAC end point configured for primary TMAC and secondary TMAC both are pointing to same TMAC.

this caused the fetching the duplicate data set and display the same agent twice.

Resolution:

In case if you find the above cause suitable ; then we can update the configuration as stated below

  • Navigate to the TMAC Data Server folder and find the TMC_Data.json
  • Find the primary and secondary IP configured in the file, update the secondary IP to the secondary server. If stand-alone setup blank value is the preferred setting.
  • Save the File and restart the TMAC Data Server Windows service to reflect the config changes
  • Move back to Agent-Desktop Supervisor console once Data Serve is up, then refresh the active agents list

Note: the  config file update depends on what type of configuration you have opted example if you deployed through TMC then the primary and secondary IP will be on the TMC_GlobalData.json. In another case if you opted 'none'/xml configuration mode then configuration file for the above is .exe.config.